Server

Krystal Network Status

Clear communication throughout service affecting events

Partial Outage on Shared & Premium Servers 2 weeks ago

We're currently investigating an issue with one of our firewalls that sits in front of all shared and premium servers. During this time, you may have intermittent connectivity however our team are working on this and will have an update shortly.

UPDATE 15:28 - Load on the firewall appears to be dropping off, however we are continuously monitoring this to ensure it stabilises fully.

UPDATE 15:33 - The issue appears to be resolved. We'll continue to monitor all core services to ensure there are no further blips to our service.

Back to Status Page
Comments