Server

Krystal Network Status

Clear communication throughout service affecting events

Iron Outage 1 week ago

Update: 21:51 We are aware of a connectivity issue to our Iron server, we are actively investigating this issue. We will report back with further details shortly, we apologise for the inconvenience caused.

Update: 22:39 This has now been fixed and we will monitor Iron for stability and performance issues.

Back to Status Page
Comments