Server

Krystal Network Status

Clear communication throughout service affecting events

Hestia Email Deliverability 3 days ago

Posted @ 01/10/2020 10:45 :-

Hestia is currently experiencing email deliverability issues to Microsoft based email addresses such as, but not limited to:

hotmail.co.uk

hotmail.com

live.co.uk

live.com

The listing is as a result of user complaints rather than large amounts of spam and we are working with Microsoft to have the listing removed as soon as possible. If any users have forwarding rules configured to their hotmail accounts, please ensure mail that is forwarded to the Microsoft email account is not junked as this negatively effects our server reputation and such email should be reported as Junk using our email filtering to prevent it being forwarded.

Users heavily impacted by this issue should contact our support team to arrange migration to one of our new shared hosting servers.

We will provide further updates as soon as additional information is available. We apologise for any disruption caused.

Update @ 05/10/2020 14:40 :-

We are continuing to work with Microsoft to remove this listing however as the process is slow we recommend that any affected users contact support to arrange migration to one of our new shared servers. Again, we apologise for any disruption caused.

Update @ 09/10/2020 10:32 :-

Unfortunately an issue with the Microsoft SNDS system has caused further delays in our attempts to delist the IP Address. We are waiting to hear back from Microsoft's SNDS team on this issue however we will provide further details as soon as possible.

Update @ 12/10/2020 10:27 :-

Mail flow appears to be returning to normal however Microsoft have not provided any information as to the issue or if the listing has been removed entirely as such we are operating under the assumption we may still be rate limited and will still be offering migration to one of our newer systems to anyone affected by this issue. We will mark this issue as resolved at the end of this week providing we see no further issues.

Update @ 12/10/2020 11:30 :-

Unfortunately it appears that we are being heavily rate limited despite Microsoft's response to us that they are unable to see any issues as such we've provided additional evidence of this problem to have the limit removed. It would appear that small amounts of mail can be sent every few hours however we do recommend avoiding mail delivery to hotmail addresses where possible as delivery may be extremely delayed.

Update @ 14/10/2020 17:26 :-

We are currently awaiting a further response from Microsoft support regarding this issue, their escalations team picked this up on the 12th however we've yet to hear back anything further on case. We will be chasing this up again tomorrow morning as we typically expect a response within 48 hours. As before, we do apologise for any disruption caused by this issue and we are doing our upmost to resolve this issue with Microsoft directly.

Update @ 16/10/2020 17:24 :-

Microsoft have been chased regarding this problem however no update has been provided at the current time. We have now chased them again for a further update due to the 'radio silence' approach they have taken. For users affected by this ongoing issue we still recommend migration to one our newest servers for the fastest resolution.

Update @ 21/10/2020 13:03 :-

Microsoft have responded advising they have now largely increased sending limits against this server's IP address as such whilst we are still rate limited, the current backlog of delayed messages will be cleared over the next few days. We will leave this status up until we are happy the issue is full resolved. We apologise that this has taken such a large amount of time to resolve, this will be fed back to Microsoft who have caused a large portion of this delay!

Back to Status Page
Comments